martes, 16 de octubre de 2012

Error «APT::Cache-Limit»

Si cuando nos disponemos a instalar un paquete nos aparece el siguiente error, es porque tenemos un problema de espacio en APT::Cache. (o algo así,  perdón por las limitaciones de la medianeurona).

Leyendo lista de paquetes... ¡Error!
E: La asignación dinámica MMap no tiene más espacio. Por favor, incrementa el valor de «APT::Cache-Limit». El valor actual es: 25000000 (man 5 apt.conf)


Para solucionarlo, le asignamos más espacio:

Creamos este fichero, si no exite.

sudo nano /etc/apt/apt.conf

Y añadimos esta línea (la cifra, ir probando hasta que una te vaya bien).

APT::Cache-Limit 55000000;

No hay comentarios:

Publicar un comentario en la entrada